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1 Introduction

About this chapter
This chapter contains important user information, descriptions of safety notices, regu-
latory information, intended use of the Biacore™ X100, and lists of associated docu-
mentation.

In this chapter

Section See page

1.1 Important user information 5

1.2 About this manual 6

1.3 Associated documentation 7

1 Introduction
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1.1 Important user information

Introduction
This section contains important user information about the product and this manual.

Read this before operating the
product

All users must read the entire Operating Instructions before installing, oper-
ating, or maintaining the product.

Always keep the Operating Instructions at hand when operating the product.

Do not install, operate, or perform maintenance on the product in any other way than
described in the user documentation. If you do, you may be exposed or expose others
to hazards that can lead to personal injury and you may cause damage to the equip-
ment.

Intended use of the product
Biacore X100 is a system for real-time label-free analysis of molecular interactions in
laboratory research. Biacore X100 is intended for research use only and shall not be
used for diagnostic purposes in any clinical or in vitro procedures.

Prerequisites
In order to operate Biacore X100 in the way it is intended:

• The user must read and understand the Safety instructions chapter in the Operating
Instructions.

• The system must be installed according to the instructions in the Installation
chapter of the Operating Instructions.

• The user must have a general understanding of the use of a personal computer
running Microsoft Windows in the version provided with your product.

• The user must be acquainted with the use of general laboratory equipment and with
handling of biological materials.

• A system administrator familiar with management of Microsoft SQL Server data-
bases is recommended. Familiarity with database management is not required for
operation of Biacore X100.

1 Introduction
1.1 Important user information
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1.2 About this manual

Introduction
This section contains information about the purpose and scope of this manual, notes
and tips, and typographical conventions.

Purpose of this manual
This manual provides information needed to install, operate and maintain the product
in a safe way.

Notes and tips
Note: A note is used to indicate information that is important for trouble-free and

optimal use of the product.

Tip: A tip contains useful information that can improve or optimize your proce-
dures.

Typographical conventions
Software items are identified in the text by bold italic text.

Hardware items are identified in the text by bold text.

Tip: The text can include clickable hyperlinks to reference information.

1 Introduction
1.2 About this manual
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1.3 Associated documentation

Introduction
This section describes the user documentation delivered with the product, and how to
find related literature that can be downloaded or ordered from Cytiva.

User documentation
The main components of the documentation for Biacore X100 are listed in the table
below. Translations of the Biacore X100 Operating Instructions are provided in PDF
format on the documentation CD inside the back cover of the printed Operating
Instructions. Other documentation is available for download from cytiva.com/biacore.
You need to register on the website to access some of these documents.

Documentation Main contents

Biacore X100 Operating Instructions
(this manual)

Instructions needed to install, operate,
and maintain Biacore X100 in a safe
way.

Biacore X100 Handbook, BR100801 Detailed system description and
instructions for preparing, running, and
evaluating experiments.

Biacore X100 Site Preparation Guide,
29145041

Requirements for space, power, and
environmental conditions for installing
and running Biacore X100.1

Biacore X100 Installation Instructions,
29288193

Instructions for installing or upgrading
the software and database.¹

Biacore Application Guides General methodology for Biacore X100,
such as principles of kinetics and affinity
analysis, sensor surface preparation,
and concentration measurements.

Support Navigator On-screen assistance for using
Biacore X100 control and evaluation
software.

1 These instructions are not required for normal use of Biacore X100.

1 Introduction
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2 Safety instructions

About this chapter
This chapter describes safety precautions, labels and symbols that are attached to the
equipment. In addition, the chapter describes emergency and recovery procedures.

In this chapter

Section See page

2.1 Safety precautions 9

2.2 Labels 15

2.3 Emergency procedures 16

Important

WARNING
All users must read and understand the entire contents of
this general safety chapter, and the specific safety precau-
tions information in each subsequent chapter of this manual
to become aware of the hazards involved.

2 Safety instructions

Biacore X100 Operating Instructions 28961142 AF 8



2.1 Safety precautions

Introduction
Biacore X100 is powered by mains voltage and handles materials that can be
hazardous. Before installing, operating or maintaining the system, you must be aware
of the hazards described in this manual.

Follow the instructions to avoid injury to the operator or other personnel,
damage to samples or other substances handled by the equipment, to the
product, or to other equipment in the area.

The safety precautions in this section are grouped in the following categories:

• General precautions

• Flammable liquids and explosive environment

• Personal protection

• Installing and moving the product

• Operation

• Maintenance

Definitions
This user documentation contains safety notices (WARNING, CAUTION, and NOTICE)
concerning the safe use of the product. See definitions below.

WARNING

WARNING indicates a hazardous situation which, if not avoided,
could result in death or serious injury. It is important not to proceed
until all stated conditions are met and clearly understood.

CAUTION

CAUTION indicates a hazardous situation which, if not avoided,
could result in minor or moderate injury. It is important not to
proceed until all stated conditions are met and clearly understood.

NOTICE

NOTICE indicates instructions that must be followed to avoid
damage to the product or other equipment.

2 Safety instructions
2.1 Safety precautions
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General precautions

WARNING

Only properly trained personnel may operate and maintain the
product.

WARNING

Do not operate the product in any other way than described in the
user documentation.

WARNING

Do not use any accessories not supplied or recommended by
Cytiva.

WARNING

Protective ground. The product must always be connected to a
grounded power outlet.

WARNING

Use only mains cables supplied or approved by Cytiva.

WARNING

Do not block the rear or side panels of the instrument. The power
switch must always be easy to access. The power cord must always
be easy to disconnect.

WARNING

Decontaminate the equipment before decommissioning to make
sure that hazardous residues are removed.

2 Safety instructions
2.1 Safety precautions
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WARNING

Hazardous waste. Waste liquids and used sensor chips may
contain hazardous, flammable or infectious substances. Dispose of
all waste products in accordance with national and local regula-
tions.

CAUTION

Waste tubes and containers must be secured and sealed to
prevent accidental spillage.

Flammable liquids and explosive
environment

WARNING

The product is not intended for use in locations with explosion risks
or fire hazards.

WARNING

Liquids marked as flammable must not be used as running buffer or
pumped reagents. Any buffer or reagent containing flammable
substances must be placed in properly capped vials in the sample
rack.

WARNING

Explosion hazard. To avoid building up an explosive atmosphere
when using flammable liquids, make sure that the room ventilation
meets the local requirements.

Personal protection

WARNING

Always wear appropriate protective clothing and equipment during
operation and maintenance of the product. Use required safety
equipment when handling hazardous substances.

2 Safety instructions
2.1 Safety precautions
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WARNING

Liquids in the buffer bottles or tubing may be toxic or flammable or
may cause chemical burns or irritation to skin and eyes. Take
appropriate precautions in the event of bottle breakage, accidental
spillage and insecure fitting of tubings to bottles.

CAUTION

The products that are used with toxic or hazardous substances
must be marked in accordance with local laws and regulations.

CAUTION

Pinch risk. Take care that fingers are not trapped by moving parts
on the instrument.

CAUTION

Accidental breakage of glass bottles may leave sharp fragments
and splinters that can cause cuts and abrasions.

Installing and moving the product

CAUTION

Wear protective shoes with steel toecaps when moving the instru-
ment to protect against falling objects.

CAUTION

Heavy object. Use proper lifting equipment, or use two or more
persons when moving the instrument. All lifting and moving must
be performed in accordance with local regulations.

CAUTION

Make sure that hands or fingers are not trapped under the instru-
ment when the instrument is lifted or moved.

2 Safety instructions
2.1 Safety precautions
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Operation

WARNING

Handle bottles carefully. Accidental breakage of buffer or water
bottles may cause flooding of the bottle tray, and liquid may come
into contact with electrical circuits, causing electric shock and/or
fire hazards.

WARNING

A fume hood or similar ventilation system shall be installed when
flammable or noxious substances are used.

CAUTION

Accidental breakage of buffer or water bottles may cause flooding
of the bottle tray, and liquid may enter the instrument enclosure. If
this happens, disconnect the instrument from the mains power and
call your local service representative.

CAUTION

Do not touch the pumps while they are moving.

CAUTION

Make sure that the waste container has sufficient space for
maximum waste volume when the equipment is left unattended.

CAUTION

Make sure that all fluidic tubes are secured and properly connected
or sealed at both ends before, during and after operation.

2 Safety instructions
2.1 Safety precautions
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Maintenance

WARNING

All service and repairs, with the exception of operations explicitly
described in the user documentation, must be carried out by
personnel authorized by Cytiva. Do not open any covers or replace
any parts unless specifically stated in the user documentation.

WARNING

The product contains mains voltage of up to 240 V AC. Disconnect
mains cord before replacing fuses. Do not remove instrument
covers.

WARNING

For continued protection from fire hazard, replace only with same
type and rating of fuse.

WARNING

The injection needle is sharp. Take care when working in the
sample compartment.

WARNING

If the instrument may be contaminated with biohazards, decon-
taminate the instrument before performing maintenance on any
instrument parts. Contact your local service representative for
further information about decontamination procedures.

2 Safety instructions
2.1 Safety precautions
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2.2 Labels

Introduction
This section describes the system label and other safety or regulatory labels that are
attached to the product.

Nameplate
The nameplate provides information about the model, manufacturer, and technical
data.

Description of symbols on the system
label

The following symbols may be present on the system label.

Symbol/text Meaning

Warning! Read the user documentation before using the system.
Do not open any covers or replace parts unless specifically stated
in the user documentation.

Product no Instrument catalog number

Code no Instrument assembly number

Serial no Instrument serial number

Mfg. Date Year (YYYY) and month (MM) of manufacture

Voltage Electrical rating: Mains voltage (VAC )

Frequency Electrical rating: Frequency (Hz)

Max Power Electrical rating: Maximum power (VA)

Fuse rating Fuse rating: number of fuses, type T (slow acting), trip current (A),
breaking capacity H (high), or maximum voltage (V)

2 Safety instructions
2.2 Labels
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2.3 Emergency procedures

Introduction
This section describes how to shut down the Biacore X100 system in an emergency
situation, and the procedure for restarting the Biacore X100 system.

The section also describes the result in the event of power failure.

NOTICE

Do not use the acute emergency stop procedure unless there is a
risk of injury, damage or loss of valuable material. All operations
including buffer flow and data collection are stopped immediately.

To stop a run under controlled conditions before it is complete, choose Run →Stop
Run Sensorgram from the menu bar in Biacore X100 Control Software . This will stop
both the run and the data collection at the end of the current cycle. A dialog is
displayed while the current cycle is finished.

Emergency shutdown

In an emergency situation, follow the steps below to stop the run.

Step Action

1 Press Ctrl-Break (Ctrl-Pause) on the keyboard to stop the run and the data
collection immediately.

2 In the dialog box that appears, click Yes if you want to wash the system with
running buffer. You should do this if possible. The wash operation takes
about 3 minutes.

NOTICE

Do not leave the system in an emergency stop condition. Always
follow the restart procedure if possible, to restore the instrument
to normal condition.

2 Safety instructions
2.3 Emergency procedures
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Power failure
The following table describes the consequences of a power failure.

Power failure
to...

will result in...

Biacore X100
instrument

• The run is interrupted immediately.

• Data collected up to and including the last cycle completed
before the power failure is saved in the result file.

Computer • The computer shuts down immediately.

• Instrument operation continues for a short time (until the
internal data buffer is full) and then stops.

• Data collected up to and including the last cycle completed
before the power failure is saved in the result file, but there
is a risk that the result file may be corrupt and cannot be
read.

Restart procedure

Follow the steps below to restart the system after an emergency shutdown.

Step Action

1 Turn on mains power if it is switched off and check that the instrument starts
normally.

2 If you need to clean the liquid handling system, eject the sensor chip and
insert a maintenance chip. See Section 6.3 Cleaning, on page 51 for further
instructions.

2 Safety instructions
2.3 Emergency procedures
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3 System description

About this chapter
This chapter gives an overview of the Biacore X100 system, and a brief description of its
function.

In this chapter

Section See page

3.1 Biacore X100 instrument 19

3.2 Indicators and switches 23

3.3 Sensor chip 24

3.4 Control system 25

3 System description
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3.1 Biacore X100 instrument

Main parts of the instrument
The main parts of the instrument are identified below.

1

3

2

4

5

6

7

8

9

10

Part Function

1 Status indicators

2 Lower front door with pump compartment and optional degasser
(included in Biacore X100 Plus Package) behind

3 Buffer tubes

4 Buffer bottle

5 Buffer tray

6 Upper front door with sensor chip port behind

7 Sample compartment with sample rack

8 Waste tubing

9 Waste bottle

10 Waste tray

3 System description
3.1  Biacore X100 instrument
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WARNING

Liquids in the buffer bottles or tubing may be toxic or flammable or
may cause chemical burns or irritation to skin and eyes. Take
appropriate precautions in the event of bottle breakage, accidental
spillage and insecure fitting of tubings to bottles.

WARNING

Waste liquids may contain hazardous or flammable substances.
Take appropriate precautions to avoid spillage of hazardous waste.

CAUTION

Accidental breakage of buffer or water bottles may cause flooding
of the bottle tray, and liquid may enter the instrument enclosure. If
this happens, disconnect the instrument from the mains power and
call your local service representative.

CAUTION

Waste tubes and containers shall be secured and sealed to prevent
accidental spillage.

Sample compartment

1

2

3

4

5

6

3 System description
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Part Function

1 Injection needle

(delivers samples and reagents to the chip)

2 Sample rack

3 Rack locked indicator lamp

4 lluminating lamps in the sample compartment ceiling

(turn on/off from the Control Software)

5 Needle wash station

(for automatic needle wash)

6 Rack base with lock

(locked/unlocked via Control Software)

NOTICE

Do not touch the rack when the Rack locked indicator on the front
panel is lit. The rack moves at times during the run and the needle
may be destroyed if the rack is prevented from moving.

Do not attempt to rotate the rack by hand in the instrument.

Connections
Connections for mains power and computer communication as illustrated below are
on the rear of the instrument at the right hand side.

PC SERVICE

1 2

3

4

Part Function

1 Computer ports

2 Mains switch

3 System description
3.1  Biacore X100 instrument
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Part Function

3 Fuse compartment

4 Mains inlet

Note: For warning texts, see Section 6.5 Replacing the mains fuses, on page 56.

3 System description
3.1  Biacore X100 instrument

Biacore X100 Operating Instructions 28961142 AF 22



3.2 Indicators and switches

Status indicators
The status indicators on the front panel are described below.

Indicator Function

Ready (green) Lit when power is on

Temperature
(yellow)

Lit when the temperature at the flow cells is stable at the
preset temperature. Flashes when the temperature is not
stable.

Sensor chip
(green)

Lit when a sensor chip is docked and ready. Flashing when a
chip is inserted but not docked.

Run (green) Lit when a run is in progress.

Mains power switch
The mains power connector and switch is located on the mains input panel, at the rear
right of the instrument (see Connections, on page 21).

3 System description
3.2 Indicators and switches
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3.3 Sensor chip
The sensor chip is a gold-coated glass slide mounted on a supporting frame. The
sensor chip is normally enclosed in a protective cassette. Do not remove the sensor
chip from the cassette. The illustration below shows the sensor chip separate from the
cassette for illustration purposes.

3

2

1

Part Function

1 Frame

2 Gold-coated glass slide

3 Cassette

3 System description
3.3 Sensor chip

Biacore X100 Operating Instructions 28961142 AF 24



3.4 Control system
Biacore X100 Control Software is a complete software for control and supervision of
Biacore X100.

Biacore X100 Evaluation Software is a stand-alone software for evaluation of results
obtained from Biacore X100. The software is normally installed on the same computer
as the Biacore X100 Control Software , although connection to the instrument is not
required for using Biacore X100 Evaluation Software.

All Biacore X100 Software includes an integrated support function with instructions
and recommendations for using the software and also for experimental design and
evaluation of results.

3 System description
3.4 Control system
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4 Installation

About this chapter
This chapter describes site requirements and preparations necessary to perform
before installation of the Biacore X100 system.

In addition, instructions are included for moving the Biacore X100 system within the
laboratory or to another building.

NOTICE

The product is prepared and installed by Cytiva personnel. Contact
Cytiva if you require re-installation at a new site.

In this chapter

Section See page

4.1 Site requirements 27

4.2 Unpacking, assembly and transport 30

4.3 Connections 31

4 Installation
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4.1 Site requirements

WARNING

Explosion hazard: A fume hood or similar ventilation system must
be used when flammable or noxious substances are used.

WARNING

Explosion hazard. To avoid building up an explosive atmosphere
when using flammable liquids, make sure that the room ventilation
meets the local requirements.

Space requirements
The size of the instrument is indicated in the illustration below. At least 20 cm clear-
ance is required on all sides of the instrument to allow adequate air circulation. Space is
also required for the PC beside the instrument. The laboratory bench must be stable
and able to support the weight of the instrument.

200 mm

200 mm

200 mm

200 mm

575 mm

600 mm
530 mm

4 Installation
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Electrical power requirements

WARNING

Protective ground. The product must always be connected to a
grounded power outlet.

WARNING

Use only mains cables supplied or approved by Cytiva.

WARNING

Do not block the rear or side panels of the instrument. The power
switch must always be easy to access. The power cord must always
be easy to disconnect.

The instrument requires mains power outlets with protective earth as specified in the
table below.

Parameter Specification

Supply voltage 100 to 240 V~

Frequency 50/60 Hz

Maximum power 400 VA

Transient overvoltages Overvoltage category II

Power outlet Grounded

4 Installation
4.1 Site requirements
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Environmental requirements
The following general requirements must be fulfilled:

• The room must have exhaust ventilation

• The instrument should not be exposed to direct sunlight

• Dust in the atmosphere should be kept to a minimum

The installation site must comply with the following specifications:

Parameter Specification

Allowed location Indoor use only

Ambient temperature, operation 18°C to 33°C

Max. relative humidity, operation 80% RH, non-condensing, up to 31°C.

Decreasing linearly to 50% RH at 40°C.

Ambient temperature, transportation/
storage

-25°C to 60°C

Altitude, operation Up to 2000 m

Pollution degree of the intended envi-
ronment

Pollution degree 2

Avoid placing the system adjacent to heaters or air conditioners.

Condensation may occur in the sample compartment at high ambient humidity. This is
normal and does not indicate any malfunction.

4 Installation
4.1 Site requirements
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4.2 Unpacking, assembly and transport

Unpacking
Biacore X100 will be unpacked by Cytiva personnel.

Check the equipment for any apparent damage before starting installation. Document
any damage carefully and contact your Cytiva representative.

Contact Cytiva if you need to re-pack Biacore X100 for storage or transport.

Assembly
Biacore X100 requires no special assembly other than that performed by Cytiva
personnel during installation.

Transport
To avoid damage, the optical unit in Biacore X100 must be secured before transport
over more than limited distances within the laboratory. Contact Cytiva for assistance.

CAUTION

Heavy object. Use proper lifting equipment, or use two or more
persons when moving the instrument. All lifting and moving must
be performed in accordance with local regulations.

CAUTION

Wear protective shoes with steel toecaps when moving the instru-
ment to protect against falling objects.

CAUTION

Make sure that hands or fingers are not trapped under the instru-
ment when the instrument is lifted or moved.

4 Installation
4.2 Unpacking, assembly and transport
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4.3 Connections

NOTICE

Do not turn on the mains power switches before all connections
are made.

Connect the instrument to the
computer

Connect a serial communication cable between the COM1 (or IOIOIA) port of the PC,
and the PC connector on the rear panel of the instrument.

The SERVICE connector is for service purposes only.

NOTICE

Any computer used with the equipment must comply with IEC
60950 or IEC 62368-1 and be installed and used according to the
manufacturer’s instructions.

PC SERVICE

To COM1 port on PC

Connect to mains power

Follow the steps below to connect the instrument to a mains power source.

Step Action

1 Connect the mains power cord delivered with the instrument, to the MAINS
INLET connector on the rear panel (see Connections, on page 21). Connect
the other end to a mains outlet with protective earth.

2 Check that any mains voltage selectors on the PC and peripheral equipment
are set correctly.

3 Install the PC and peripheral equipment according to the respective instruc-
tion manuals.

4 Installation
4.3 Connections
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WARNING

Do not block the rear or side panels of the instrument. The power
switch must always be easy to access. The power cord must always
be easy to disconnect.

4 Installation
4.3 Connections
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5 Operation

About this chapter
This chapter gives instructions on how to operate the product in a safe way.

In this chapter

Section See page

5.1 Overview 35

5.2 Starting the instrument 36

5.3 Preparing, loading and changing buffers 39

5.4 Inserting a sensor chip 40

5.5 Setting the analysis temperature 42

5.6 Preparing and loading samples and reagents 43

5.7 Starting a run 45

5.8 Post-run procedures 46

Safety precautions

WARNING

Always wear appropriate protective clothing and equipment during
operation and maintenance of the product. Use required safety
equipment when handling hazardous substances.

WARNING

Do not use any accessories not supplied or recommended by
Cytiva.

5 Operation
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WARNING

Handle bottles carefully. Accidental breakage of buffer or water
bottles may cause flooding of the bottle tray, and liquid may come
into contact with electrical circuits, causing electric shock and/or
fire hazards.

WARNING

Liquids in the buffer bottles or tubing may be toxic or flammable or
may cause chemical burns or irritation to skin and eyes. Take
appropriate precautions in the event of bottle breakage, accidental
spillage and insecure fitting of tubings to bottles.

WARNING

Waste liquids may contain hazardous or flammable substances.
Take appropriate precautions to avoid spillage of hazardous waste.

CAUTION

The products that are used with toxic or hazardous substances
must be marked in accordance with local laws and regulations.

CAUTION

Ensure that all fluidic tubes are secured and properly connected or
sealed at both ends before, during and after operation.

CAUTION

Waste tubes and containers shall be secured and sealed to prevent
accidental spillage.

CAUTION

Accidental breakage of glass bottles may leave sharp fragments
and splinters that can cause cuts and abrasions.

5 Operation
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5.1 Overview
The typical workflow for performing a run in Biacore X100 is shown in the table below.
Some analyses may require several runs to complete the experiment.

Stage Description More information

1 Create a workflow or
wizard template, or use a
previously saved workflow.

Biacore X100 Handbook or soft-
ware support

2 Prepare buffers and
samples.

Section 5.3 Preparing, loading and
changing buffers, on page 39 and 
Section 5.6 Preparing and loading
samples and reagents, on page 43

3 Start the run. Section 5.7 Starting a run,
on page 45

4 Finish the run. Section 5.8 Post-run procedures,
on page 46

5 Evaluate the results. Biacore X100 Handbook or soft-
ware support

5 Operation
5.1 Overview
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5.2 Starting the instrument

Introduction
This section describes how to start the instrument from shutdown or from standby
mode.

Start the instrument from shutdown

NOTICE

If you have the Biacore X100 Plus Package, always keep the buffer
tubes in liquid when the instrument is powered on to prolong the
life of the degasser.

Follow the steps below to start the system from shutdown.

Step Action

1 Switch on the PC.

2 Open the lower front door on the instrument and close the cover of the peri-
staltic pump. Close the door before continuing.

3 Switch on the instrument (see Connections, on page 21). The status indica-
tors on the front panel light during initiation (see Status indicators,
on page 23). When the initiation is ready, Power is lit, the Temperature
lamp is lit or flashes, Sensor chip is not lit or flashes and Run is not lit.

4 Start Biacore X100 Control Software .

5 Operation
5.2 Starting the instrument
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Step Action

5 In the login-dialog, enter your user name and password and click OK.

Verify that the correct database connection is selected in the drop-down list.

6 The software establishes connection with the instrument, which takes about
30 seconds.

7 Make sure that there is fresh buffer or water in the bottle on the left-hand
tray and that both buffer tubes are inserted into the bottle.

8 Make sure that the waste bottle on the right-hand tray is empty and the
waste tube is inserted in the bottle.

9 The system event log is displayed in the software and the startup procedure
is recommended. Click Run now and follow the instructions on the screen. A
previously used chip can be docked for the startup procedure (see Section
5.4 Inserting a sensor chip, on page 40 for instructions on docking a sensor
chip).

Once the startup procedure is finished, the instrument is automatically left
in standby mode.

Start the instrument from standby

The instrument is normally left in standby mode which allows new runs to be started
quickly. Follow the steps below to start from standby.

Step Action

1 Start Biacore X100 Control Software if it is not already running.

2 In the login-dialog, enter your user name and password and click OK.

Verify that the correct database connection is selected in the drop-down list.

3 The software establishes connection with the instrument, which takes about
30 seconds.
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Step Action

4 Make sure that there is fresh buffer or water in the bottle on the left-hand
tray and that both buffer tubes are inserted into the bottle.

5 Make sure that the waste bottle on the right-hand tray is empty and the
waste tube is inserted in the bottle.

5 Operation
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5.3 Preparing, loading and changing buffers

NOTICE

Always use fresh water. Replace water before each run, or at least
every 48 hours. Do not run the system without water.

Prepare buffer
Select buffer type depending on your specific experiments. For many protein interac-
tions you may use HBS-EP+ buffer supplied by Cytiva.

Use degassed deionized water when preparing buffers to prevent problems with air
bubbles during the run. If the instrument is equipped with the degasser provided with
Biacore X100 Plus Package, you do not need to degas the water.

Always use buffer, fresh for the day and filtered through a 0.22 µm filter to remove
particles. A volume of 200 mL is suitable for use during 24 hours.

Load buffer
Fill a clean buffer bottle with buffer and place it on the left-hand tray. Insert the two
buffer tubes. The flow system is filled with buffer automatically when a chip is docked
(see Section 5.4 Inserting a sensor chip, on page 40).

If the system is in standby, follow the instructions in Start the instrument from standby,
on page 37.

Change buffer
If you need to change buffer when the instrument is in standby, select Tools →Stop
Standby to stop the standby and change the buffer bottle. When both buffer tubes are
inserted in the new buffer, select Tools →Prime to fill the system with the new buffer.
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5.3 Preparing, loading and changing buffers

Biacore X100 Operating Instructions 28961142 AF 39



5.4 Inserting a sensor chip
Follow the steps below to insert a sensor chip into the instrument.

Step Action

1 Open the upper front door of the instrument.

2 Click the Undock chip icon, or select Undock Chip from the Tools menu.
When undocking is completed, the Dock Chip dialog is displayed and the
sensor chip lamp on the front flashes.

3 Pull out the chip slide.

4 If required, remove the old chip.
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Step Action

5 Insert the chip with the text on the upper side and the arrow pointing into
the instrument.

6 Push the chip slide all the way in.

7 Close the front door and check that the buffer tubes are placed in a bottle of
buffer.

8 Complete in the information in the Dock Chip dialog and click Dock Chip.

The chip is docked and the standby flow of buffer over the chip starts automatically.
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5.5 Setting the analysis temperature
The SPR signal is sensitive to changes in temperature. It is important that a constant
temperature is maintained at the sensor chip surface throughout the run. The detec-
tion area housing the sensor chip is maintained at a precisely controlled temperature.

The analysis temperature is fixed at 25°C in the standard instrument. With the optional
Biacore X100 Plus Package, the analysis temperature can be set to 4°C to 40°C
(maximum 10°C below ambient temperature).

The analysis temperature is displayed in the status bar at the bottom of the screen.

Unstable temperature is indicated by

• a flashing Temperature indicator on the instrument front panel,

• a flashing temperature in the Control Software status bar and

• a note in the event log in the Control Software during a run.
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5.6 Preparing and loading samples and reagents

Samples and reagents

Different reagents are used depending on the type of run to be performed. The require-
ments for your assay are displayed in the rack position list in the Control Software
when the assay is set up (see example illustration below). The volumes specified in the
rack position list are minimum volumes with due consideration for dead volumes. If
dilution of samples is needed, dilute in degassed running buffer.

Follow the steps below to prepare samples and reagents.

Step Action

1 Prepare the samples and reagents in 1.5 mL conical vials (available from
Cytiva) according to the volumes and concentrations in the rack position list.
Make sure there are no visible air bubbles in the tubes. Cap the vials to avoid
evaporation during the run. Use only caps supplied for this purpose by
Cytiva.

2 Fill the 4 mL vial with distilled water. Always use fresh water filtered through
a 0.22 µm filter to remove particles. Do not cap the 4 mL vial! The water is
used for cleaning the needle during the run and during standby.

3 Load the rack as described below.

Load the rack

Follow the steps below to load the rack in the instrument.

Step Action

1 Click Load Samples in the Rack Positions dialog. You can also load the
rack using the Load Samples icon in the toolbar if you do not have an appli-
cation wizard open.

2 Wait until the Rack locked indicator below the rack compartment is
switched off.

3 Lift out the rack and place the sample and reagent vials and the water vial
according to the rack position list.
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Step Action

4 Insert the rack in the sample compartment and make sure it sits properly on
the rack base.

5 Click OK in the Load Samples dialog.
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5.7 Starting a run
Runs are programmed and started from a workflow, an application wizard or via a
manual run. Details of how to program a run may be found in the Biacore X100 Hand-
book and in the integrated software support.

Before starting a run:

• Check that there is sufficient buffer in the buffer bottle, and that both buffer tubings
are properly inserted in the buffer.

• Check that the waste bottle has sufficient space for the waste from the run and that
the waste tubing is properly inserted in the bottle cap.

• Check that samples and reagents are in position in the sample rack, in properly
capped vials.

• Check that an uncapped vial with water is in the rack position marked H2O.

• Check that the rack is properly mounted and locked (the Rack locked indicator
should be lit).
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5.8 Post-run procedures

Introduction
After a run, take care of the chip (see below) and choose whether to leave the instru-
ment in standby or perform a shutdown (see Leave the instrument, on page 46).

Remove the sensor chip

When... Then...

The sensor chip will be
reused in next run

Leave the chip in the instrument and make sure there is
enough buffer in the buffer bottle for the standby period.

The sensor chip will be
reused in a later run but
not in the next run

Remove the chip and store the chip wet or dry according
to recommendations in the Biacore Sensor Surface
Handbook .

Insert an old chip or the maintenance chip and start
standby.

The sensor chip will not
be used again

Leave the chip in the instrument or replace it with the
maintenance chip and start standby.

Leave the instrument

When... Then...

If the instrument will be
used within 7 days

Prepare the system for standby.

If the instrument will
not be used for more
than 7 days

Perform a shutdown.

See Section 6.7 Storage, on page 59 for details of these procedures.
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6 Maintenance

About this chapter
This chapter summarizes user maintenance procedures. If more extensive service is
required, please contact your Cytiva service representative. Complete the appropriate
Health and Safety Declaration Form before contacting your local service representa-
tive or returning the system for maintenance or service.

WARNING

All service and repairs, with the exception of operations explicitly
described in the user documentation, must be carried out by
personnel authorized by Cytiva. Do not open any covers or replace
any parts unless specifically stated in the user documentation.

WARNING

Always wear appropriate protective clothing and equipment during
operation and maintenance of the product. Use required safety
equipment when handling hazardous substances.

CAUTION

Pinch risk. Take care that fingers are not trapped by moving parts
on the instrument.

6 Maintenance
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6.1 Maintenance preparations

Important
Make sure that the BIAmaintenance Kit is available before starting maintenance
procedures.

Regular maintenance of Biacore X100 is essential for reliable results. It is important to
keep the instrument free from contamination such as microbial growth and adsorbed
proteins in the liquid handling system.

Regular checks and maintenance should be done according to the schedules below.
You will be reminded of the need for Desorb, Desorb and Sanitize and System
Check and Pump Calibration procedures via the scheduler displayed in the system
event log. Do not ignore maintenance reminders for more than a day or so!

To display the system event log, click View →System Event log.

Safety precautions

WARNING

Decontaminate the instrument before performing maintenance on
any instrument parts. Contact your local service representative for
further information about decontamination procedures.

WARNING

Concentrated disinfectant solution is corrosive. Use appropriate
personal protective equipment when handling such solutions..

NOTICE

Some maintenance procedures will destroy the ligand on a
prepared sensor chip. Always use the separate Sensor Chip Main-
tenance that is included in the Maintenance Kit unless otherwise
stated.

NOTICE

Do not use BIAdesorb solution 1 at analysis temperatures below
20°C. BIAdesorb solution 1 precipitates at low temperatures.
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6.2 Maintenance summary
Regular checks and maintenance should be done according to the schedule below.

Interval Action Required material

Daily/after
each run

Empty the waste bottle None

Weekly Clean the flow system1: Insert a Sensor
Chip Maintenance, select Tools
→More Tools →Desorb and follow the
instructions on the screen.

BIAdesorb solutions1
and 2, Sensor Chip Main-
tenance, deionized and
filtered water

Inspect tube fittings and pumps for
possible leaks

None

Monthly Clean and disinfect the flow system:
Insert a Sensor Chip Maintenance,
select Tools →More Tools →Desorb
and Sanitize and follow the instruc-
tions on the screen.

BIAdesorb solutions 1
and 2, disinfectant solu-
tion (see Clean and sani-
tize the flow system,
on page 52 for recom-
mendations), Sensor
Chip Maintenance,
deionized and filtered
water

Perform a System Check and Pump
Calibration:

Insert a new Sensor Chip CM5, select
Tools →More Tools →System Check
and Pump Calibration and follow the
instructions on screen.

Biacore test solution,
HBS-EP+ buffer, new
Sensor Chip CM5

Inspect the needle and needle wash
station, and look for accumulations of
salt or protein.

None

Inspect the sample compartment, look
for signs of flooding

None

Clean the instrument cover None

1 For some applications, a coating of protein on the flow system walls helps to give reproducible
results, and the first few cycles after Desorb may be unreliable. If you observe this behavior, run
Desorb when you change your protein system rather than once a week.
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6.3 Cleaning
 

Cleaning the instrument

WARNING

Liquids in the buffer bottles or tubing may be toxic or flammable or
may cause chemical burns or irritation to skin and eyes. Take
appropriate precautions in the event of bottle breakage, accidental
spillage and insecure fitting of tubings to bottles.

If necessary, clean the cover of the processing unit with a moist cloth. Use water or a
mild detergent.

The buffer tray and the waste and water tray can be removed for cleaning.

If necessary, clean the waste bottle cap as follows:

Step Action

1 Unscrew the cap from the waste bottle.

2 Loosen the tube fittings and remove the tubes from the cap.

3 Rinse the cap in deionized water.

4 Re-attach the tubes to the cap and tighten the fittings firmly.

Cleaning before planned
maintenance/service

To ensure the protection and safety of service personnel, all equipment and work areas
must be clean and free of any hazardous contaminants before a Service Engineer
starts maintenance work.

Complete the checklist in the On Site Service Health and Safety Declaration Form or
the Health and Safety Declaration Form for Product Return or Servicing, depending on
whether the instrument is going to be serviced on site or returned for service, respec-
tively.
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Clean the needle and wash station

WARNING

Liquids in the buffer bottles or tubing may be toxic or flammable or
may cause chemical burns or irritation to skin and eyes. Take
appropriate precautions in the event of bottle breakage, accidental
spillage and insecure fitting of tubings to bottles.

WARNING

The injection needle is sharp. Take care when working in the
sample compartment.

Clean the needle and wash station if you see that salt or other deposits have accumu-
lated. You will need deionized water, lint-free tissues, and an hex key to remove the
shield (supplied with the instrument).

Run Tools →More Tools →Clean needle and needle wash station and follow the
instructions on the screen.

Clean the instrument cover
If necessary, clean the cover of the instrument with a moist cloth. Use water or a mild
detergent. The buffer tray and the waste tray can be removed for cleaning. If salt resi-
dues or proteins have accumulated on the buffer bottle cap, clean the cap in deionized
water.

Clean and sanitize the flow system
Tools for cleaning and disinfecting the flow system are available under Maintenance
Tools in the More Tools menu. For regular cleaning, use Desorb or Desorb and Sani-
tize from the Tools →More Tools menu for cleaning and sanitizing the flow system.

The table below summarizes the tools provided.

Note: BIAdesorb solution 1 will precipitate at low temperature and should not be
used at analysis or sample compartment temperatures below 20°C. To run
Desorb below 20°C, replace BIAdesorb solution 1 with 0.5% lithium dodecyl
sulfate in water.
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Tool Description Required materials

Desorb Cleans the flow system. Run at least once
a week, or more often if necessary.1

BIAdesorb solution 1
Biadesorb solution 2

Desorb
and sani-
tize

Cleans and disinfects the flow system. Run
at least once a week, or more often if
necessary.1

BIAdesorb solution 1

Biadesorb solution 2

disinfectant solution

HBS buffer

Empty
buffer
tubing

Washes and empties all buffer tubing. Run
whenever you intend to leave buffer
tubing unused for an extended period.

70% ethanol

BIAdesorb solution 2

Wash
buffer
tubing

Washes one or all buffer tubes. Run after
using buffers containing substances that
tend to adsorb to the tubing, e.g. deter-
gent or serum albumin.

BIAdesorb solution 1
Biadesorb solution 2

1 Use Sensor Chip Maintenance or a used chip for the procedure. The solutions used may damage
the ligand on sensor chips used for assays.

BIAdesorb solution 1 and 2 are provided in BIAmaintenance Kit. Sodium hypochlorite
(0.6% to 1.0% active chlorine) is recommended as disinfectant solution. Instructions
for preparing the solution from commercial sodium hypochlorite solutions can be
found in BIAmaintenance Kit. Do not use hydrogen peroxide-based disinfectants or
other products that release gases on use.

Use Superclean if the regular cleaning procedures are not sufficient.

The following solutions are required for the Superclean procedure:

• Deionized water (filtered 0.22 µm) at 40°C to 50°C

• 1% acetic acid

• 0.2 M sodium bicarbonate

• 6 M guanidine-HCl

• 10 mM HCl

Note: If low molecular weight analytes have been used, use 50% DMSO and 10%
DMSO instead of guanidine-HCl and HCl respectively.

Normalizing the detector
This procedure adjusts the detector response to compensate for slight differences in
individual sensor chips. For best performance, run this procedure once for each new
chip. The procedure can either be run before immobilization or before the first run
using the immobilized chip. Normalization injects BIAnormalizing solution (70% glyc-
erol in water) over the chip surface.

Required solutions: BIAnormalizing solution

At the start of a run

6 Maintenance
6.3 Cleaning

Biacore X100 Operating Instructions 28961142 AF 53



Check the Normalize detector option in the System Preparations workspace,
which appears before the start of each run.

At any other time

Run the maintenance tool Normalize to normalize the detector response for all flow
cells.

NOTICE

Run Normalize with the sensor chip that will be used for the run.
Do not use Sensor Chip Maintenance for this purpose.
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6.4 Component maintenance

Check for leaks
The pump compartment is placed behind the lower front door. Once a week, check that
there are no liquid or salt deposits at the positions shown in the illustration below.

1

2

3

4

5
6

7

Part Function

1 Peristaltic pump

2 Peristaltic pump tube fittings

3 Degasser tube fittings (only included with Biacore X100 Plus Package)

4 Syringe pump tube fittings

5 Syringe pump

6 Syringe pump barrel (below the plunger)

7 Syringe pump plunger fitting

Check system performance
Run System check and pump calibration from the Tools →More Tools menu to
check the peristaltic pump calibration, detector response, sample injection perform-
ance and signal noise. This tool saves the results of the test as a data item and provides
a detailed report that can be priunted. If any test parameters in the report fall outside
acceptance limits, contact your Cytiva representative.
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6.5 Replacing the mains fuses

WARNING

Disconnect power. Always disconnect power from the instru-
ment before replacing fuses.

WARNING

For continued protection from fire hazard, replace only with same
type and rating of fuse.

CAUTION

Do not replace the mains fuses if you suspect that there may be a
malfunction in the instrument. Contact your Cytiva service repre-
sentative for advice.

Follow the steps below to replace the mains fuses.

Step Action

1 Turn off the power to the Biacore X100 instrument.

2 Disconnect the mains cord from the mains power inlet.

3 Insert a small screwdriver under the tab on the fuse drawer cover.

4 Prise open the fuse drawer cover.
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Step Action

5 Replace both fuses.

See the instrument product label for fuse ratings.

6 Close the fuse drawer cover and reconnect the mains supply.
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6.6 Calibration
The peristaltic pump is calibrated with the System check and pump calibration tool
from the Tools →More Tools menu.

Needle positioning is calbrated with the Replace needle tool from the Tools →More
Tools menu.

All other calibration of Biacore X100 is performed by Cytiva.
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6.7 Storage

Standby
Leave the system in standby mode if it is to be used within the next 7 days.

Biacore X100 is automatically placed in standby mode after the end of each run. In
standby mode the instrument maintains a continuous low flow of buffer or water from
the left hand bottle through the flow system to prevent accumulation of buffer resi-
dues and to preserve the ligand on the chip. Standby can run uninterrupted for up to 7
days.

If you intend to leave the instrument for up to 7 days, check that you have:

• a chip docked in the instrument

• at least 120 mL buffer or water in the buffer bottle with buffer tubes inserted

• a full water vial in the rack (the water is used for regular washes of the needle to
minimize salt deposits)

• an empty waste bottle

You may restart the standby again after 7 days, after checking the list above.

Note: We recommend that you use distilled and filtered water instead of buffer to
minimize salt deposits. However, if an immobilized sensor chip is docked
and will be used later, buffer may be necessary to preserve the sensor
surface during standby.

Note: During the standby period you can leave the same buffer in the instrument
for up to 7 days. However, if you start a new run, change to a buffer fresh for
the day.

 

Starting standby manually

To start standby manually, select Tools →Standby in the Control Software. If you want
to close the software but leave the instrument in standby, select File →Exit, choose
Standby in the dialog that is displayed, and click Next.

Shutdown

If the instrument is to be left unused for more than 7 days or if the instrument will be
moved, perform a shutdown.

It is recommended to run Desorb and sanitize and also Clean needle and needle
wash station before starting the shutdown procedure.

The shutdown procedure flushes the flow system first with distilled water, then with
70% ethanol and finally with air to dry the system.

 

Required materials

• Deionized water (filtered 0.22 µm)

• 70% ethanol

6 Maintenance
6.7 Storage

Biacore X100 Operating Instructions 28961142 AF 59



 

Shutting down the instrument

Follow the steps below to shut down the instrument.

Step Action

1 Prepare 2 bottles: one with distilled and filtered water and the other one with
70% ethanol.

2 Choose File →Exit and then select Shutdown or choose Tools →Shut-
down.

Follow the instructions on the screen.

The procedure flushes the flow system and then empties the flow system of
liquid. The total run time is about 10 minutes.

When instructed, open the lower front door and open the cover of the peri-
staltic pump to release the clamping of the pump tube.

3 Exit from Biacore X100 Control Software if it is still running.

4 Remove the bottles, and the buffer bottle cap assembly. Clean the bottle
trays if required. Insert the buffer tubes in an empty bottle.

The chip is undocked during the Shutdown procedure. An undocked chip is
indicated with a flashing Sensor chip status indicator.

You may remove the chip if desired: pull out the chip slide behind the upper
front door and lift out the chip.

Storage conditions
Maintain normal conditions of temperature and humidity while the system is in
storage:

• Temperature: preferably room temperature, not below freezing

• Relative humidity: non-condensing, preferably low humidity

Contact Cytiva if you are uncertain of storage conditions.

After storage, start up the system as described in Start the instrument from shutdown,
on page 36 and run System check and pump calibration from the Tools →More
Tools menu before performing any experiments.
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7 Troubleshooting

About this chapter
This chapter gives a brief guide to troubleshooting procedures for problems with
Biacore X100.

To avoid problems, follow the instructions and recommendations given in this manual.
Clean and maintain the instrument regularly as described in Chapter 6 Maintenance,
on page 47. If you are experiencing problems that you cannot correct, contact your
local service representative.

In this chapter

Section See page

7.1 Instrument related problems 62

7.2 Other problems 66
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7.1 Instrument related problems

General considerations

Problem Action

Proteins and other substances adsorb to the
walls of the flow system, giving carry-over
problems between assays.

Clean the flow system with Desorb
more often than once a week.

Carry-over problems persist after Desorb
and Sanitize.

Run Tools →More Tools →Super-
clean.

Salt residues or other deposits have accu-
mulated on the needle or needle wash
station.

Clean the needle and wash station.

The needle is obstructed or damaged. Replace the needle (Tools →More
Tools →Replace Needle).

Sample consumption is unexpectedly low,
sensorgrams are irregular.

Run Tools →More Tools →Flow
system wash.

The System Check and Pump Calibration
shows incorrect volume delivery from the
peristaltic pump.

Replace the peristaltic pump tube

(Tools →More Tools →Replace
Peristaltic Pump Tube).

The syringe leaks or salt residues accumu-
late below the syringe piston.

Replace the pump syringe (Tools
→More Tools →Replace Syringe).

Damaged needle

If the needle is damaged, check the following:

Possible cause Action

Unsuitable caps have been
used on the vials.

Ensure that only caps supplied by Cytiva are used
to cap the 1.5 mL sample and reagent vials. Never
cap the water vial.

Change the needle as described below.

Unsuitable vials have been
used.

Ensure that only recommended vials are used,
see Section 8.1 Specifications, .

Change the needle as described below.

Rack movement was
obstructed during a run.

Change the needle as described below.
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Possible cause Action

The rack mechanism does not
function correctly.

Contact your local Cytiva service representative.

Follow the steps below to change the needle.

Step Action

1 To replace the needle, select Tools →More Tools →Replace Needle and
follow the instructions on the screen.

2 When the needle replacement and calibration is finished, select Tools
→Standby to start standby.

System check and pump calibration

Before contacting your local service representative, run the System Check and Pump
Calibration tool. The results of this procedure can help your service representative to
identify problems. In some cases you may be able to correct the problem yourself.

Follow the steps below to perform a System check and pump calibration procedure.

Step Action

1 Insert a new Sensor Chip CM5.

2 Choose Tools →More Tools →System Check and Pump Calibration.
Follow the instructions on the screen to prepare and start the procedure.

3 The results from the procedure are displayed automatically after the run.
Test results are marked as PASS or FAIL.

If any test failed, perform the action(s) according to the table below and then
repeat the System Check and Pump Calibration.

If the problem persists, contact your local Cytiva service representative.

Use the table below to evaluate the results of the System check and pump calibra-
tion procedure.

Failed test Action

A: Peristaltic
pump calibra-
tion

Check that the pump cover is properly closed.

Check that the buffer tubes reach the buffer liquid and that they
are not squeezed.

Check that the pump tube does not leak and has not been punc-
tured by mistake.

If the test fails repeatedly, change the pump tube.
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Failed test Action

B: Response If the Fc-values in the results are too low, check that you used a
non-immobilized Sensor Chip CM5.

If the Fc-values in the result are too low or too high, check that you
used the correct buffer (HBS-EP+ buffer) and test solution
(Biacore test solution).

C: Injections Check that the tubes do not leak.

Contact your local Cytiva service representative.

D: Noise Check that you used a non-immobilized Sensor Chip CM5.

Check that the temperature stability is not affected by inade-
quate ventilation, exposure to direct sunlight or similar.

Liquid flow problems

Problem Possible cause Action

Buffer is not supplied
properly.

There is not enough
buffer in the buffer
bottle.

Ensure that there is enough buffer
before starting the run.

The cover of the peri-
staltic pump is not
properly closed.

Close the cover.

The flow system is
leaking.

Check for leaks (Check for leaks,
on page 55).

Air is injected during
sample or reagent
injections.

Insufficient volumes
of sample and/or
reagents.

Ensure that you use the volumes
specified in the software for the
run. Larger volumes may be
needed if the problem persists.

Ensure that you use the recom-
mended caps for sample and
reagent vials. Evaporation from
uncovered vials will both affect
the concentration and reduce the
volume.

Perform a System Check and
Pump Calibration to calibrate
the peristaltic pump.

Samples become
cross-contami-
nated.

Not enough water to
clean the injection
needle.

Always fill the water vial in the
rack before starting the run.
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Temperature problems
If the analysis temperature is unstable (the Temperature indicator flashes) for more
than one hour after the temperature has been set, check that:

• there is at least 20 cm clearance around the instrument to allow adequate circula-
tion.

• the instrument is not placed adjacent to heaters, cooling ducts, or in direct sunlight.

Other instrument-related problems
Unexpected detection results may appear if there are dust or other particles on the
sensor chip surface. Never remove the sensor chip from its protective cassette.
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7.2 Other problems

Software problems
In the case of software malfunction or other software problem, run Tools →More Tools
→Software Problem Report. Complete the problem report in as much detail as you
can, save the report and submit it to your local service representative. Attach any other
information you think may be relevant such as screendumps or exported database
items. Details of your computer, operating system and installed software are automat-
ically included in the report.

Assay-related problems
The Support Navigator in the software provides help on assay related problems. If
you cannot solve your problems with the information provided, contact your local
application support specialist.
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8 Reference information

About this chapter
This chapter lists the technical specifications of Biacore X100. The chapter also
includes a chemical resistance guide and Health and Safety Declaration forms for
service.

In this chapter
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8.1 Specifications

General

Parameter Value

Automation Maximum 15 samples, 24 h unattended operation

Molecular weight detection Down to 100 Da in various sample environments

Required sample volume Injection volume + 20 to 30 µL (application
dependent)

Sample/reagent capacity 15 sample/reagent vials, volume 1.5 mL 1 water
vial, volume 4 mL

Analysis time per sample Typically 5 to 15 min

Detection limit Typically 0.1 nM for >10 000 Da analytes. Typically
1 nM for <10 000 Da analytes.

Typical range for kinetics:

Association rate constant (ka):

Dissociation rate constant
(kd):

 

103 to 107 M-1s-1 (for protein-protein interactions)

10-5 to 0.1 s-1

Number of flow cells 2

Flow cell height Approximately 0.05 mm

Flow cell volume Approximately 0.06 µL

Instrument

Parameter Value

Dimensions w × d × h (see also 
Space requirements, on page 27)

600 × 530 × 575 mm

Net weight 47 kg

Supply voltage Autorange 100 to 240 V~, protective earthing

Maximum voltage fluctuation ± 10% from the nominal voltage

Frequency 50/60 Hz

Fuses 2 × T4.0AH 250 V

Maximum power consumption 400 VA
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Parameter Value

Altitiude Up to 2000 m

Overvoltage category II

Ambient temperature range 18°C to 33°C

Ambient humidity ≤ 80% RH

Analysis temperature Without Biacore X100 Plus Package: 25°C.

With Biacore X100 Plus Package: 4°C to 40°C,
max. 10°C below ambient temperature

System controller and software

Parameter Value

Computer require-
ments

Refer to the Biacore X100 data file.

Note:
Using a computer supplied by Cytiva is recommended.

Database Refer to the Biacore X100 data file for information about
included database and compatibility with other databases.

Power requirements
and consumption

Refer to the manufacturer's instructions.

Sample rack

Parameter Value

Capacity 15 sample vials + 1 water vial

Sample/reagent vials1 1.5 mL, conical bottom, with cap

Water vial1 4 mL, flat bottom, no cap

1 Use only vials and caps from Cytiva.

Liquid containers

Parameter Value

Running buffer 500 mL, screw cap

Waste 50 mL, screw cap
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8.2 Chemical resistance
This section gives some general guidelines concerning chemical resistance for
Biacore X100 components. Regarding exposure to solutions not covered by these
guidelines, contact your Cytiva representative for recommendations.

The flow system and sensor chip are the only parts of Biacore X100 that come into
contact with solutions. The guidelines in this section relate to tubing and connectors,
selector valves, connector block, IFC and sensor chip. In most analysis situations, the
ligand attached to the sensor surface limits the chemical resistance of the system as a
whole.

In general, the flow system components withstand long-term exposure to common
aqueous buffer solutions used in biochemical laboratories. The table below lists
compatibility with other common substances.

Concentrated organic solvents as well as long-term exposure to extremes of pH (<3
and >11) should be avoided. For solutions with short-term compatibility, do not use as
running buffer or for injections longer than 10 minutes. Solutions classed as long-term
compatible may be used as running buffer.

Solution Concentration Compatibility

Acetonitrile 50% Short term

Dimethyl formamide (DMF) 50% Short term

Dimethyl sulfoxide (DMSO) 50%

10%

Short term

Long term

Ethanol 70%

10%

Short term

Long term

Ethylene glycol 100% Short term

Formic acid 70% Short term

Formamide 40% Long term
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8.3 Recycling information

Introduction
This section contains information about the decommissioning of the product.

CAUTION

Always use appropriate personal protective equipment when
decommissioning the equipment.

Decontamination
The product must be decontaminated before decommissioning. All local regulations
must be followed with regard to scrapping of the equipment.

Disposal of the product
When taking the product out of service, the different materials must be separated and
recycled according to national and local environmental regulations.

Recycling of hazardous substances

The product contains hazardous substances. Detailed information is available from
your Cytiva representative.

Disposal of electrical components

Waste electrical and electronic equipment must not be disposed of as unsorted munic-
ipal waste and must be collected separately. Contact an authorized representative of
the manufacturer for information concerning the decommissioning of the equipment.

Disposal of batteries
Waste batteries and accumulators must not be disposed of as unsorted municipal
waste and must be collected separately. Follow applicable local regulations for recy-
cling of batteries and accumulators.

Biacore X100 contains a lithium backup battery, which must not be disposed of in fire.
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8.4 Regulatory information

Introduction
This section lists the regulations and standards that apply to the product. Your system
is marked or listed according to the applicable regulatory requirements for your region.
Local language translations are only provided according to regulatory requirements.

In this section

Section See page

8.4.1 Contact information 73
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8.4.3 Great Britain 75
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76

8.4.5 North America 78

8.4.6 China 79
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8.4.1 Contact information

Introduction
This section shows the contact information for support and manufacturing informa-
tion.

Contact information for support
To find local contact information for support and sending troubleshooting reports, visit 
cytiva.com/contact.

Manufacturing information
The table below summarizes the required manufacturing information.

Requirement Information

Name and address of manufacturer Cytiva Sweden AB

Björkgatan 30

SE 751 84 Uppsala

Sweden

Telephone number of manufacturer + 46 771 400 600
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8.4.2 European Union and European Economic Area

Introduction
This section describes regulatory information for the European Union and European
Economic Area that applies to the product.

Conformity with EU Directives
See the EU Declaration of Conformity for the directives and regulations that apply for
the CE marking.

If not included with the product, a copy of the EU Declaration of Conformity is available
on request.

CE marking

The CE marking and the corresponding EU Declaration of Conformity is valid for the
product when it is:

• used according to the Operating Instructions or user manuals, and

• used in the same state as it was delivered, except for alterations described in the
Operating Instructions or user manuals.
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8.4.3 Great Britain

Introduction
This section describes regulatory information for Great Britain that applies to the
product.

Conformity with UK Regulations
See the UK Declaration of Conformity for the regulations that apply for the UKCA
marking.

If not included with the product, a copy of the UK Declaration of Conformity is available
on request.

UKCA marking

The UKCA marking and the corresponding UK Declaration of Conformity is valid for the
product when it is:

• used according to the Operating Instructions or user manuals, and

• used in the same state as it was delivered, except for alterations described in the
Operating Instructions or user manuals.
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8.4.4 Eurasian Economic Union (Евразийский
экономический союз)

This section describes the information that applies to the product in the Eurasian
Economic Union (the Russian Federation, the Republic of Armenia, the Republic of
Belarus, the Republic of Kazakhstan, and the Kyrgyz Republic).

Introduction
This section provides information in accordance with the requirements of the Tech-
nical Regulations of the Customs Union and (or) the Eurasian Economic Union.

Введение
В данном разделе приведена информация согласно требованиям Технических
регламентов Таможенного союза и (или) Евразийского экономического союза.

Manufacturer and importer
information

The following table provides summary information about the manufacturer and
importer, in accordance with the requirements of the Technical Regulations of the
Customs Union and (or) the Eurasian Economic Union.

Requirement Information

Name, address and telephone
number of manufacturer

See Manufacturing information

Importer and/or company for
obtaining information about
importer

Cytiva RUS LLC

109004, Moscow

internal city area Tagansky municipal
district

Stanislavsky str., 21, building 5, premises I,
offices 24,25,29

Russian Federation

Telephone: +7 985 192 75 37

E-mail: rucis@cytiva.com

Информация о производителе и
импортере

В следующей таблице приводится сводная информация о производителе и
импортере, согласно требованиям Технических регламентов Таможенного союза
и (или) Евразийского экономического союза.
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Требование Информация

Наименование, адрес и номер
телефона производителя

См. Информацию об изготовлении

Импортер и/или лицо для
получения информации об
импортере

ООО "Цитива РУС"

109004, г. Москва

вн. тер. г. муниципальный округ
Таганский

ул. Станиславского, д. 21 стр. 5, помещ. I,
ком. 24,25,29

Российская Федерация

Телефон: +7 985 192 75 37

Адрес электронной почты: 
rucis@cytiva.com

Description of symbol on the
nameplate
Описание символов на заводской
табличке

This Eurasian compliance mark indicates that the product is
approved for use on the markets of the Member States of the
Customs Union of the Eurasian Economic Union

Данный знак о Евразийском соответствии указывает, что
изделие одобрено для использования на рынках
государств-членов Таможенного союза Евразийского
экономического союза
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8.4.5 North America

Introduction
This section describes the information that applies to the product in the USA and
Canada.

FCC compliance
This device complies with part 15 of the FCC Rules. Operation is subject to the following
two conditions: (1) This device may not cause harmful interference, and (2) this device
must accept any interference received, including interference that may cause unde-
sired operation.

Note: The user is cautioned that any changes or modifications not expressly
approved by Cytiva could void the user’s authority to operate the equip-
ment.

This equipment has been tested and found to comply with the limits for a Class A digital
device, pursuant to part 15 of the FCC Rules. These limits are designed to provide
reasonable protection against harmful interference when the equipment is operated in
a commercial environment. This equipment generates, uses, and can radiate radio
frequency energy and, if not installed and used in accordance with the instruction
manual, may cause harmful interference to radio communications. Operation of this
equipment in a residential area is likely to cause harmful interference in which case the
user will be required to correct the interference at his own expense.
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8.4.6 China
This section describes the information that applies to the product in China.

有害物质声明 (DoHS)
Declaration of Hazardous Substances
(DoHS)

根据 SJ/T11364-2014《电子电气产品有害物质限制使用标识要求》特提供如下
有关污染控制方面的信息。
The following product pollution control information is provided according to SJ/
T11364-2014 Marking for Restriction of Hazardous Substances caused by electrical
and electronic products.

电子信息产品污染控制标志说明
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Explanation of Pollution Control
Label

该标志表明本产品含有超过中国标准 GB/T 26572 《电子电气产品中限用物质的
限量要求 》中限量的有害物质。标志中的数字为本产品的环保使用期，表明本
产品在正常使用的条件下，有毒有害物质不会发生外泄或突变，用户使用本产
品不会对环境造成严重污染或对其人身、财产造成严重损害的期限。单位为
年。
为保证所申明的环保使用期限，应按产品手册中所规定的环境条件和方法进行
正常使用，并严格遵守产品维修手册中规定的定期维修和保养要求。
产品中的消耗件和某些零部件可能有其单独的环保使用期限标志，并且其环保
使用期限有可能比整个产品本身的环保使用期限短。应到期按产品维修程序更
换那些消耗件和零部件，以保证所申明的整个产品的环保使用期限。
本产品在使用寿命结束时不可作为普通生活垃圾处理，应被单独收集妥善处
理。
This symbol indicates the product contains hazardous materials in excess of the limits
established by the Chinese standard GB/T 26572 Requirements of concentration limits
for certain restricted substances in electrical and electronic products. The number in
the symbol is the Environment-friendly Use Period (EFUP), which indicates the period
during which the hazardous substances contained in electrical and electronic prod-
ucts will not leak or mutate under normal operating conditions so that the use of such
electrical and electronic products will not result in any severe environmental pollution,
any bodily injury or damage to any assets. The unit of the period is “Year”.

In order to maintain the declared EFUP, the product shall be operated normally
according to the instructions and environmental conditions as defined in the product
manual, and periodic maintenance schedules specified in Product Maintenance Proce-
dures shall be followed strictly.

Consumables or certain parts may have their own label with an EFUP value less than
the product. Periodic replacement of those consumables or parts to maintain the
declared EFUP shall be done in accordance with the Product Maintenance Procedures.

This product must not be disposed of as unsorted municipal waste, and must be
collected separately and handled properly after decommissioning.
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有害物质的名称及含量
Name and Concentration of
Hazardous Substances

产品中有害物质的名称及含量
Table of Hazardous Substances’ Name and Concentration

部件名称
Compo-
nent name

有害物质
Hazardous substance

铅
(Pb)

汞
(Hg)

镉
(Cd)

六价铬
(Cr(VI))

多溴联苯
(PBB)

多溴二苯醚
(PBDE)

14110073 X 0 0 0 0 0

0: 表示该有害物质在该部件所有均质材料中的含量均在 GB/T 26572 规定的
限量要求以下。

X: 表示该有害物质至少在该部件的某一均质材料中的含量超出 GB/T 26572
规定的限量要求。

• 此表所列数据为发布时所能获得的最佳信息.

0: Indicates that this hazardous substance contained in all of the homogeneous
materials for this part is below the limit requirement in GB/T 26572.

X: Indicates that this hazardous substance contained in at least one of the
homogeneous materials used for this part is above the limit requirement in
GB/T 26572

• Data listed in the table represents best information available at the time of
publication.
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8.4.7 General regulatory statements

Introduction
This section shows regulatory statements that are applicable to more than one
geographical region.

EMC emission, CISPR 11: Group 1,
Class A statement

NOTICE

This equipment is not intended for use in residential environments
and may not provide adequate protection to radio reception in
such environments.

Compliance statement

NOTICE

Class A equipment (equipment for business use).

This equipment has been evaluated for its suitability for use in a
business environment.

When used in a residential environment, there is a concern of radio
interference.

유의사항
A급 기기 (업무용 방송통신 기자재)

이 기기는 업무용환경에서 사용할 목적으로 적합성평가를 받
은 기기
로서 가정용 환경에서 사용하는 경우 전파간섭의 우려가 있습
니다.
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8.4.8 Other regulations and standards

Introduction
This section describes the additional standards that apply to the product.

Regulatory compliance of connected
equipment

Any electrical equipment connected to Biacore X100 shall meet the safety require-
ments of EN/IEC 61010-1, or other relevant national safety regulations and standards.
Within EU, connected equipment must be CE marked.
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8.5 Ordering information
Ordering information for Biacore X100 and related products can be found on 
cytiva.com/biacore.
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8.6 Health and Safety Declaration Form

On site service

 

 
 
 

Service Ticket #: 
 

 

To make the mutual protection and safety of Cytiva service personnel and our customers, all equipment and work areas must be 
clean and free of any hazardous contaminants before a Service Engineer starts a repair. To avoid delays in the servicing of your 
equipment, complete this checklist and present it to the Service Engineer upon arrival. Equipment and/or work areas  
not sufficiently cleaned, accessible and safe for an engineer may lead to delays in servicing the equipment and could be subject to 
additional charges. 
 

 Yes  No 
Review the actions below and answer “Yes” or “No”.  
Provide explanation for any “No” answers in box below. 

 

 

 

 

 

 

Instrument has been cleaned of hazardous substances. 
Rinse tubing or piping, wipe down scanner surfaces, or otherwise make sure removal of any dangerous residue. 
Make sure the area around the instrument is clean. If radioactivity has been used, perform a wipe test or other 
suitable survey. 

 

 

 

 

Adequate space and clearance is provided to allow safe access for instrument service, repair or 
installation. In some cases this may require customer to move equipment from normal operating location 
prior to Cytiva arrival. 

 

 

 

 
Consumables, such as columns or gels, have been removed or isolated from the instrument and from 
any area that may impede access to the instrument . 

  All buffer / waste vessels are labeled.  
Excess containers have been removed from the area to provide access. 

Provide 
explanation 
for any “No” 
answers here: 

 

Equipment type / Product No:  Serial No:  

I hereby confirm that the equipment specified above has been cleaned to remove any hazardous substances and that the area 
has been made safe and accessible. 

Name:  Company or institution:    

Position or 
job title: 

 Date (YYYY/MM/DD):  

Signed: 
 

Cytiva and the Drop logo are trademarks of Global Life Sciences IP Holdco LLC or an affiliate. 

© 2020 Cytiva. 
All goods and services are sold subject to the terms and conditions of sale of the supplying company operating 
within the Cytiva business. A copy of those terms and conditions is available on request. Contact your local Cytiva 
representative for the most current information. 

For local office contact information, visit cytiva.com/contact. 
28980026 AD 04/2020 

On Site Service Health &
Safety Declaration Form
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Product return or servicing

 

Health & Safety Declaration Form 
for Product Return or Servicing 

 
 

Return authorization 
number: 

 and/or 
Service Ticket/Request: 

 

To make sure the mutual protection and safety of Cytiva personnel, our customers, transportation personnel and our environment, 

all equipment must be clean and free of any hazardous contaminants before shipping to Cytiva. To avoid delays in the processing of 

your equipment, complete this checklist and include it with your return. 

1. Note that items will NOT be accepted for servicing or return without this form 

2. Equipment which is not sufficiently cleaned prior to return to Cytiva may lead to delays in servicing the equipment and 

could be subject to additional charges 

3. Visible contamination will be assumed hazardous and additional cleaning and decontamination charges will be applied 

 Yes   No Specify if the equipment has been in contact with any of the following: 

  Radioactivity (specify)  

  Infectious or hazardous biological substances (specify)  

  Other Hazardous Chemicals (specify)  

Equipment must be decontaminated prior to service / return. Provide a telephone number where Cytiva can contact 
you for additional information concerning the system / equipment. 

Telephone No:   

Liquid and/or gas in equipment is:  Water 

 Ethanol 

 None, empty 

 Argon, Helium, Nitrogen 

 Liquid Nitrogen 

Other, specify  

Equipment type / Product No:  Serial No:  

I hereby confirm that the equipment specified above has been cleaned to remove any hazardous substances and that 
the area has been made safe and accessible. 

Name: 
 Company or 

institution:   
 

Position or job title:  Date (YYYY/MM/DD)  

Signed:   

Cytiva and the Drop logo are trademarks of Global Life Sciences IP Holdco LLC or an affiliate. 

© 2020 Cytiva. 
All goods and services are sold subject to the terms and conditions of sale of the supplying company operating 
within the Cytiva business. A copy of those terms and conditions is available on request. Contact your local Cytiva 
representative for the most current information. 

For local office contact information, visit cytiva.com/contact. 
28980027 AD 04/2020 

To receive a return authorization number 
or service number, call local 
technical support or customer service.  
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Safety notices, 9
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Give feedback on this document

Visit cytiva.com/techdocfeedback or
scan the QR code.

cytiva.com/biacore
Cytiva and the Drop logo are trademarks of Life Sciences IP Holdings Corp. or an affiliate doing business
as Cytiva.

Biacore is a trademark of Global Life Sciences Solutions USA LLC or an affiliate doing business as Cytiva.

Microsoft and Windows are registered trademarks of Microsoft group of companies.

Any other third-party trademarks are the property of their respective owners.

© 2020–2023 Cytiva

Any use of software may be subject to one or more end user license agreements, a copy of, or notice of
which, are available on request.

For local office contact information, visit cytiva.com/contact

28961142 AF V:9 05/2023
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